const regex = /^.*(\/\/damn.at)\/(.*)(\?go-get=)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(\\\/\\\/damn.at)\\\/(.*)(\\?go-get=)(.*)', 'gm')
const str = `https://damn.at/tests?go-get=1
https://damn.at/dd?go-get=1
https://damn.at/fuck/more/shit?go-get=1`;
const subst = `https://go.damn.at/go.php?pkg=$2&get=1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);