import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*(\\/\\/damn.at)\\/(.*)(\\?go-get=)(.*)";
final String string = "https://damn.at/tests?go-get=1\n"
+ "https://damn.at/dd?go-get=1\n"
+ "https://damn.at/fuck/more/shit?go-get=1";
final String subst = "https://go.damn.at/go.php?pkg=$2&get=1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}