// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*(\/\/damn.at)\/(.*)(\?go-get=)(.*)").unwrap();
let string = "https://damn.at/tests?go-get=1
https://damn.at/dd?go-get=1
https://damn.at/fuck/more/shit?go-get=1";
let substitution = "https://go.damn.at/go.php?pkg=$2&get=1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}