use strict;
my $str = 'https://damn.at/tests?go-get=1
https://damn.at/dd?go-get=1
https://damn.at/fuck/more/shit?go-get=1';
my $regex = qr/^.*(\/\/damn.at)\/(.*)(\?go-get=)(.*)/mp;
my $subst = 'https://go.damn.at/go.php?pkg=$2&get=1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";