$re = '/^.*(\/\/damn.at)\/(.*)(\?go-get=)(.*)/m';
$str = 'https://damn.at/tests?go-get=1
https://damn.at/dd?go-get=1
https://damn.at/fuck/more/shit?go-get=1';
$subst = "https://go.damn.at/go.php?pkg=$2&get=1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;