#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*(\/\/damn.at)\/(.*)(\?go-get=)(.*)"
Local $sString = "https://damn.at/tests?go-get=1" & @CRLF & _
"https://damn.at/dd?go-get=1" & @CRLF & _
"https://damn.at/fuck/more/shit?go-get=1"
Local $sSubst = "https://go.damn.at/go.php?pkg=$2&get=1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)