# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([\s\S]*)\s[^\s]*$/$1.../gm;t' <<< "The Boy Bands Have Won, and All"