$re = '/^([\s\S]*)\s[^\s]*$/m';
$str = 'The Boy Bands Have Won, and All';
$subst = "$1...";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;