re = /^([\s\S]*)\s[^\s]*$/m
str = 'The Boy Bands Have Won, and All'
subst = '$1...'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result