using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\s\S]*)\s[^\s]*$";
string substitution = @"$1...";
string input = @"The Boy Bands Have Won, and All";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}