const regex = /^([\s\S]*)\s[^\s]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\s\\S]*)\\s[^\\s]*$', 'gm')
const str = `The Boy Bands Have Won, and All`;
const subst = `$1...`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);