use strict;
my $str = 'The Boy Bands Have Won, and All';
my $regex = qr/^([\s\S]*)\s[^\s]*$/mp;
my $subst = '$1...';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";