using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+),([^,]*),([^,]*?)(?:\r?\n|$)";
string substitution = @"$1, ""$2"", ""$3""\n";
string input = @"id, text field1, text field2
1,some text,another text
2,some text,another text
3,some text,another text
1,some text,another text
2,some
text,another text
3,some text,another text
1,some text,another text
2,some
1999-06-21 text,another text
3,some text,another text";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}