use strict;
my $str = 'id, text field1, text field2
1,some text,another text
2,some text,another text
3,some text,another text
1,some text,another text
2,some
text,another text
3,some text,another text
1,some text,another text
2,some
1999-06-21 text,another text
3,some text,another text';
my $regex = qr/(\d+),([^,]*),([^,]*?)(?:\r?\n|$)/p;
my $subst = '$1, "$2", "$3"\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";