// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d+),([^,]*),([^,]*?)(?:\r?\n|$)").unwrap();
let string = "id, text field1, text field2
1,some text,another text
2,some text,another text
3,some text,another text
1,some text,another text
2,some
text,another text
3,some text,another text
1,some text,another text
2,some
1999-06-21 text,another text
3,some text,another text";
let substitution = "$1, \"$2\", \"$3\"\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}