import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+),([^,]*),([^,]*?)(?:\\r?\\n|$)";
final String string = "id, text field1, text field2\n"
+ "1,some text,another text\n"
+ "2,some text,another text\n"
+ "3,some text,another text\n"
+ "1,some text,another text\n"
+ "2,some \n"
+ "text,another text\n"
+ "3,some text,another text\n"
+ "1,some text,another text\n"
+ "2,some \n"
+ "1999-06-21 text,another text\n"
+ "3,some text,another text";
final String subst = "$1, \"$2\", \"$3\"\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}