const regex = /(\d+),([^,]*),([^,]*?)(?:\r?\n|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+),([^,]*),([^,]*?)(?:\\r?\\n|$)', 'g')
const str = `id, text field1, text field2
1,some text,another text
2,some text,another text
3,some text,another text
1,some text,another text
2,some
text,another text
3,some text,another text
1,some text,another text
2,some
1999-06-21 text,another text
3,some text,another text`;
const subst = `$1, "$2", "$3"\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);