import re
regex = re.compile(r"(\d+),([^,]*),([^,]*?)(?:\r?\n|$)")
test_str = ("id, text field1, text field2\n"
"1,some text,another text\n"
"2,some text,another text\n"
"3,some text,another text\n"
"1,some text,another text\n"
"2,some \n"
"text,another text\n"
"3,some text,another text\n"
"1,some text,another text\n"
"2,some \n"
"1999-06-21 text,another text\n"
"3,some text,another text")
subst = "$1, \"$2\", \"$3\"\\n"
result = regex.sub(subst, test_str)
if result:
print(result)