# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?|\d{2}(?=\d{9}$)|\d{3}(?!$))\K/ /g;t' <<< "90000800123987"