re = /(?|\d{2}(?=\d{9}$)|\d{3}(?!$))\K/
str = '90000800123987'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result