using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|\d{2}(?=\d{9}$)|\d{3}(?!$))\K";
string substitution = @" ";
string input = @"90000800123987";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}