use strict;
my $str = '90000800123987';
my $regex = qr/(?|\d{2}(?=\d{9}$)|\d{3}(?!$))\K/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";