$re = '/(?|\d{2}(?=\d{9}$)|\d{3}(?!$))\K/';
$str = '90000800123987';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;