#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:\G(?!^)|\bDenti)[^\W_]*\K_"
Local $sString = "Foo_Bar_baz Denti_Cal_Project_Status Baz_bar"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)