re = /(?:\G(?!^)|\bDenti)[^\W_]*\K_/
str = 'Foo_Bar_baz Denti_Cal_Project_Status Baz_bar'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result