use strict;
my $str = 'Foo_Bar_baz Denti_Cal_Project_Status Baz_bar';
my $regex = qr/(?:\G(?!^)|\bDenti)[^\W_]*\K_/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";