$re = '/(?:\G(?!^)|\bDenti)[^\W_]*\K_/';
$str = 'Foo_Bar_baz Denti_Cal_Project_Status Baz_bar';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;