import re
regex = re.compile(r"(?:\G(?!^)|\bDenti)[^\W_]*\K_")
test_str = "Foo_Bar_baz Denti_Cal_Project_Status Baz_bar"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)