#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*[A-Z].*"
Local $sString = "iPhone X" & @CRLF & _
"Nokia 9;" & @CRLF & _
"Huawei Nexus 6P" & @CRLF & _
"Samsung Galaxy S8" & @CRLF & _
"LG G6" & @CRLF & _
"Xiaomi MI6" & @CRLF & _
"Sony Xperia Z5" & @CRLF & _
"Asus Zenfone 3" & @CRLF & _
"Meizu Pro 6" & @CRLF & _
"Heizu Pro 6" & @CRLF & _
"pixel 2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")