re = /.*[A-Z].*/m
str = 'iPhone X
Nokia 9;
Huawei Nexus 6P
Samsung Galaxy S8
LG G6
Xiaomi MI6
Sony Xperia Z5
Asus Zenfone 3
Meizu Pro 6
Heizu Pro 6
pixel 2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end