using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*[A-Z].*";
string input = @"iPhone X
Nokia 9;
Huawei Nexus 6P
Samsung Galaxy S8
LG G6
Xiaomi MI6
Sony Xperia Z5
Asus Zenfone 3
Meizu Pro 6
Heizu Pro 6
pixel 2
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}