use strict;
my $str = 'iPhone X
Nokia 9;
Huawei Nexus 6P
Samsung Galaxy S8
LG G6
Xiaomi MI6
Sony Xperia Z5
Asus Zenfone 3
Meizu Pro 6
Heizu Pro 6
pixel 2
';
my $regex = qr/.*[A-Z].*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}