import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*[A-Z].*";
final String string = "iPhone X\n"
+ "Nokia 9;\n"
+ "Huawei Nexus 6P\n"
+ "Samsung Galaxy S8\n"
+ "LG G6\n"
+ "Xiaomi MI6\n"
+ "Sony Xperia Z5\n"
+ "Asus Zenfone 3\n"
+ "Meizu Pro 6\n"
+ "Heizu Pro 6\n"
+ "pixel 2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}