const regex = new RegExp('.*[A-Z].*', 'gm')
const str = `iPhone X
Nokia 9;
Huawei Nexus 6P
Samsung Galaxy S8
LG G6
Xiaomi MI6
Sony Xperia Z5
Asus Zenfone 3
Meizu Pro 6
Heizu Pro 6
pixel 2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}