// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*[A-Z].*").unwrap();
let string = "iPhone X
Nokia 9;
Huawei Nexus 6P
Samsung Galaxy S8
LG G6
Xiaomi MI6
Sony Xperia Z5
Asus Zenfone 3
Meizu Pro 6
Heizu Pro 6
pixel 2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}