# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.{1,29})\s/$1, /gm;t' <<< "the quick brown fox jumped over the lazy dog near the bank of the river by 123 4567 8901234 567 89012 3456 789abc 012345 67890"