use strict;
my $str = 'the quick brown fox jumped over the lazy dog near the bank of the river by 123 4567 8901234 567 89012 3456 789abc 012345 67890';
my $regex = qr/(.{1,29})\s/mp;
my $subst = '$1, ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";