re = /(.{1,29})\s/m
str = 'the quick brown fox jumped over the lazy dog near the bank of the river by 123 4567 8901234 567 89012 3456 789abc 012345 67890'
subst = '$1, '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result