package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.{1,29})\s`)
var str = `the quick brown fox jumped over the lazy dog near the bank of the river by 123 4567 8901234 567 89012 3456 789abc 012345 67890`
var substitution = "$1, "
fmt.Println(re.ReplaceAllString(str, substitution))
}