const regex = /(.{1,29})\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.{1,29})\\s', 'gm')
const str = `the quick brown fox jumped over the lazy dog near the bank of the river by 123 4567 8901234 567 89012 3456 789abc 012345 67890`;
const subst = `$1, `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);