import Foundation
let pattern = #"(.{1,29})\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"the quick brown fox jumped over the lazy dog near the bank of the river by 123 4567 8901234 567 89012 3456 789abc 012345 67890"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1, "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)