#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(range|append):(\d+,?)+$"
Local $sString = "range:50,100,200,300,400asgfasf" & @CRLF & _
"append:200,400" & @CRLF & _
"range:20,40" & @CRLF & _
"range" & @CRLF & _
"append:" & @CRLF & _
"range:123" & @CRLF & _
"range:123,12,123,23423"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")