import re
regex = re.compile(r"^(range|append):(\d+,?)+$", flags=re.MULTILINE)
test_str = ("range:50,100,200,300,400asgfasf\n"
"append:200,400\n"
"range:20,40\n"
"range\n"
"append:\n"
"range:123\n"
"range:123,12,123,23423")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")