using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(range|append):(\d+,?)+$";
string input = @"range:50,100,200,300,400asgfasf
append:200,400
range:20,40
range
append:
range:123
range:123,12,123,23423";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}