// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(range|append):(\d+,?)+$").unwrap();
let string = "range:50,100,200,300,400asgfasf
append:200,400
range:20,40
range
append:
range:123
range:123,12,123,23423";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}