const regex = /^(range|append):(\d+,?)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(range|append):(\\d+,?)+$', 'gm')
const str = `range:50,100,200,300,400asgfasf
append:200,400
range:20,40
range
append:
range:123
range:123,12,123,23423`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}