$re = '/^(range|append):(\d+,?)+$/m';
$str = 'range:50,100,200,300,400asgfasf
append:200,400
range:20,40
range
append:
range:123
range:123,12,123,23423';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);