import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(range|append):(\\d+,?)+$";
final String string = "range:50,100,200,300,400asgfasf\n"
+ "append:200,400\n"
+ "range:20,40\n"
+ "range\n"
+ "append:\n"
+ "range:123\n"
+ "range:123,12,123,23423";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}