# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/\/([\w-]+\.)+(\w+).*/\/\/$1$2/gm;t' <<< "https://site.ru
http://assembly.site.com
http://civil-law.site.ru/wist/vved.html
https://ru.site.net/wiki/О_культе_личности_и_его_последствиях._Доклад_XX_съезду_КПСС_(Н.С._Хрущёв)"