const regex = new RegExp('//([\\w-]+\\.)+(\\w+).*', 'gm')
const str = `https://site.ru
http://assembly.site.com
http://civil-law.site.ru/wist/vved.html
https://ru.site.net/wiki/О_культе_личности_и_его_последствиях._Доклад_XX_съезду_КПСС_(Н.С._Хрущёв)`;
const subst = `//$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);